Unable to load data in Jira Cloud
Incident Report for 55 Degrees
Resolved
The underlying issue is resolved. Our monitoring shows that more and more users are successfully loading data with the new data loader build. We have a small number of customers who are still getting presented with the cached version of the build, and we are working with them through the support portal. Please contact us if you are affected by entering a support request at support.55degrees.se.

We’re sorry for the frustration and inconvenience this has caused our users. We will be doing a post-mortem of this incident to find actions we can take to prevent these kinds of caching issues in the future.
Posted Feb 28, 2023 - 21:40 CET
Update
We are continuing to monitor, but the issue seems to be resolved for users once browser cache is cleared and we can confirm that the updated code is loaded into the user's app. We are also seeing a reduced number of users hitting the old data loader code in our logs.

Users can follow the steps in these videos to help determine if remaining problems are due to cache that still needs to be cleared or if there is a separate problem to report:

1. Verify if you are getting a cached version of the data loader (https://www.loom.com/share/3c20c8f3b8f34ac18c79e635595288a2)
2. Test disabling browser cache to see if it fixes a problem (https://www.loom.com/share/31dedcdde7934f028dc896d40db41d96)

If issues still occur after following those two steps, please report the issue at https://support.55degrees.se, as the issue is caused by a separate problem.

We will send another update within 2 hours.
Posted Feb 28, 2023 - 17:25 CET
Monitoring
We disabled our server cache, re-deployed code, then re-enabled our server cache.

All users who have no browser cache set or have cleared their browser's cache should no longer experience any issues.

If you continue to experience issues with opening dialogues from the Data Set menu, please try clearing your browser's cache. If that doesn't work, please try a different browser until the cache resets.

We're monitoring our logs to ensure users are no longer hitting the old data loader code and are able to load the new version.

Next update in 1 hour.
Posted Feb 28, 2023 - 16:14 CET
Identified
We've determined that caching is causing the malfunction in data loading.

We can confirm that when cache is disabled on a browser, the app functions correctly.

We're working to reset cache across the board to reduce user impact. In the meantime you can use a different browser than normal or attempt to reset your browser cache.

Next update in 15 minutes.
Posted Feb 28, 2023 - 15:54 CET
Investigating
We are experiencing an issue in which dialogs are not responding correctly from the data set dropdown. Instead, the users just see spinning loaders. The result is that users cannot load data.

We believe this is related to a deployment we made earlier today. We are actively investigating in order to decide the best course of action.
Posted Feb 28, 2023 - 14:55 CET
This incident affected: ActionableAgile for Jira Cloud.